VNC pointer glitch

Report your issues here

VNC pointer glitch

Postby mc123 » Tue Jun 12, 2012 2:41 pm

Remoter VNC has been my favorite iOS VNC app for several months, but recently I've been having a small issue. I'm using Remoter Complete on an iPad 3 running iOS 5.1 to connect to a Mac running 10.6.8.

Beginning with version 3.6.1 and continuing in 3.6.2, the pointer does not render properly in a VNC session. For example, when I first start a session, the pointer is the standard black arrow. When I move it over a text field, it changes to the text input cursor, but when I move it away, it never changes back to the arrow. If I move the pointer over a link, it will change to the hand cursor, but again, it will never change back to the arrow no matter where I move it. Depending on where I move it, the pointer will switch back and forth from the text cursor to the hand to the column-resizing cursor, but it will never return to the arrow until I end the session and begin a new one. Reverting back to 3.6.0 restores normal behavior, and the pointer on the remote computer is not affected by the Remoter issue.

This problem seems to be purely cosmetic as the clicking, selection and dragging functions are normal; however, it is an annoyance as it's not always clear where to position the wrongly-shaped pointer in order to properly register a click, and the text cursor tends to disappear against dark backgrounds.

I haven't seen anyone else post about this problem, so I don't know if mine is an isolated case or not. If you need any more information, please let me know. Thanks.
mc123
 
Posts: 2
Joined: Tue Jun 12, 2012 1:56 pm

Re: VNC pointer glitch

Postby raf » Wed Jul 11, 2012 2:57 pm

Thanks for the report!,

Version 3.6+ includes enhancements to memory management of the VNC cursor. We'll look into the scenario you describe to see what's going on -- possibly the icon needs more memory than is allowed currently, and all we need to do is increase a memory threshold.

Thanks!,

http://trac.remoterlabs.com/index.fcgi/ticket/478

Raf.

(PS: Sorry for the delay to respond! The move is finally over. Forum support is back to normal.)
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am

Re: VNC pointer glitch

Postby mc123 » Sat Oct 13, 2012 8:00 pm

This bug seems to be resolved with version 3.8.2. Thank you!
mc123
 
Posts: 2
Joined: Tue Jun 12, 2012 1:56 pm

Re: VNC pointer glitch

Postby raf » Mon Oct 15, 2012 11:02 am

Great to hear this is finally resolved!

Thanks,
Raf
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am


Return to Support

Who is online

Users browsing this forum: No registered users and 5 guests