Import SSH Keys

Report your issues here

Import SSH Keys

Postby g34258769 » Thu Jul 14, 2016 9:49 am

I cannot figure out how to get an SSH Key imported using Clipboard on an iOS device. Every time I try nothing happens. When I click on SSH manager and import, I get "monitoring for SSH keys", but it seems that no matter what I do, I cannot get a key to import.

It is unfeasible for me to create a new key (remote sites), or to use iTunes (would need to find a PC to do this on and this would be the only reason why I would need iTunes at this point).

I have tried uploading the key to dropbox, and then copying (by holding down and using the dialog menu on the key), or copying the text to clipboard, or copying the text to a note and then seeing if it would import. I've tried e-mailing it to myself, in both text and as an attachment.

I looked for a guide and did not see one. Do you have any instructions on how to import an external ssh key, other than iTunes and generating a new one.

Thanks. I've used the product for at least the last 2 years. This has always bugged me, and in the past, I generated new keys for a few sites. Now I have expanded, and that isn't something that is worth the time.

Edit: I apologize, I had to run before posting the below information


remoter version ( in app: settings -> help/about ) --- v4.8.04
device remoter is installed on ( iPhone 3, iPad 1, etc ) --- iphone 6 and ipad air
iOS version ( on device: settings -> general -> about -> Version ) -- 9.3.2

Problem Specific

what type of session (telnet, ssh, etc) --- ssh key autentication
server specifics (OSX, Linux, Windows, emulation, etc) --- linux server
connection (LAN to LAN, WAN to LAN, UPnP, subnet, etc) --- doesn't matter. Cannot import the key
error message, odd screen (screen capture can be great help -- on device: press power + home button at the same time) --- no error message. Nothing other than the initial "monitoring for keys"
related settings for both session and global - N / A
reveal any other info you think may help

Extra Mile

try to reproduce the problem, clarify if it's consistent or not if possible --- I haven't been able to import the key at all, ever, even after the feature became available, unless it is through iTunes
orientation of screen/device (rotation) - try both landscape and portrait --- n / a
check out whats known, fixed and planned in the bug tracking system - ok.
Posts: 1
Joined: Thu Jul 14, 2016 9:22 am

Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest