HowTo: Send special characters like pipe, '@' in RDP session

Report your issues here

HowTo: Send special characters like pipe, '@' in RDP session

Postby Franky » Fri Dec 14, 2012 10:19 am

Hi,

using 3.8.5 (was same with 3.8.3) on my iPad I (iOS 5.0.1, enu) I am unable to send special characters to RDP sessions.
No matter if I use sg, enu or enu(uk) kb layout on the iPad, the remote system (WinXP enu, Win7x64 enu, Win2k3 ger) only receives
7 instead of a pipe
6 instead of an ampersand
g instead of @
...etc.
When I enable Unicode support the received characters are 7'littlesquare', 6'littlesquare' and g'littlesquare' respectively.

So how to I send the full set of keys to the remote machine in an RDP session?

Thank you,
Franky
Franky
 
Posts: 12
Joined: Fri Dec 14, 2012 4:40 am

Re: HowTo: Send special characters like pipe, '@' in RDP ses

Postby Franky » Fri Dec 14, 2012 11:23 am

I played around a bit and set global keyboard settings to 'Direct'. That solved it for RDP (not VNC, the other post).
BTW: Your description in the software is wrong/misleading: It says "...mapping mode to use for VNC. Most...". No word about RDP, SSH whatever.
Franky
 
Posts: 12
Joined: Fri Dec 14, 2012 4:40 am

Re: HowTo: Send special characters like pipe, '@' in RDP ses

Postby raf » Fri Dec 14, 2012 12:12 pm

I was going to suggest also changing the "RDP Unicode" setting in the session editor for your RDP session (under advanced).
This setting allows all extended and all international (w/respect to US) characters to be handled correctly by the RDP server.

Raf.
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am

Re: HowTo: Send special characters like pipe, '@' in RDP ses

Postby Franky » Fri Dec 14, 2012 12:27 pm

Franky wrote:When I enable Unicode support the received characters are 7'littlesquare', 6'littlesquare' and g'littlesquare' respectively.
Franky
 
Posts: 12
Joined: Fri Dec 14, 2012 4:40 am

Re: HowTo: Send special characters like pipe, '@' in RDP ses

Postby raf » Fri Dec 14, 2012 12:31 pm

Right, sorry I missed that.
So you resolved the issue by selecting Direct keyboard mapping + unicode, correct?

Thanks,
Raf.
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am

Re: HowTo: Send special characters like pipe, '@' in RDP ses

Postby Franky » Fri Dec 14, 2012 12:38 pm

yes, correct.
Unfortunately that is not the solution for VNC (see other post) and the global setting for both connection types have to be the same. Don't wanna fiddel around before each other connection.
Franky
 
Posts: 12
Joined: Fri Dec 14, 2012 4:40 am


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron
cron