"Disconnected : Error connecting to server"

Report your issues here

"Disconnected : Error connecting to server"

Postby bekais » Thu Nov 18, 2010 2:36 am

Just downloaded the Remoter onto my iphone, and also downloaded ultravnc onto my desktop pc. I can't seem to find anywhere where it shows how to set up each device in order to make it work. I set up both the iphone and pc, but any time I try and connect to my pc, it comes up with a pop up on my iphone stating "Disconnected- Error connecting to server". Any ideas?

PC is xp
Tried with and without router inline
dsl connection

Thank you in advance!

Bekais
bekais
 
Posts: 1
Joined: Thu Nov 18, 2010 2:29 am

Re: "Disconnected : Error connecting to server"

Postby raf » Thu Nov 18, 2010 1:53 pm

Hi!,

If you haven't already, please look at the setup instructions inside Remoter, available by pressing the "Help" button on the top toolbar.

For more detailed instructions, you can refer to the guides found here:
viewtopic.php?f=6&t=5

The document right now is geared towards a Mac server, but all the general details still apply.

Let me know if you still need more help!,

Thanks,

Raf.
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am

Re: "Disconnected : Error connecting to server"

Postby Igel » Tue Jan 25, 2011 6:06 pm

Hi there,

have the same problem:

I bought the app because the description said I can use it with Linux. However, so far all I ever get is above Error message. Also, I couldn't find any guide for Linux or indeed any guide telling me what to try if I run into problems with the standard configuration. Could someone please help or at least report that they got it running on Linux?

I run OpenSuse 11.1 and there seem to be at least two VNC servers running:
tightvnc and xorg-x11-Xvnc. Furthermore, there is a desktop utility: KDE Desktop Sharing (Kdr) which probably uses one of the two servers.

I allowed uninvited connections in the Kdr and I also entered vncpasswd at the command prompt, defining the same password for both applications. The Kdr uses port 5900 by default. I also created an invitation by Kdr.

The connection to the iphone should be via my WLAN router (from German Telecom).

On the iphone I entered the IP-address of my WLAN card of the computer as host (192.168.2.100). This address is assigned by the router. As a 2nd try I entered the port additionally: 192.168.2.100:5900. None worked.
In the "advanced" options I entered my login name at the Linux computer and tried with and without "Request Username", "Request Password". Again, no difference. As "Server Type" I chose Linux OS. Last I entered the MAC Address of the WLAN card and the "Broadcast IP" 192.168.2.255 that "ifconfig" reported for the WLAN card.

There are so many things to configure and I'm no expert.

So I need HELP! Please?
Igel
 
Posts: 3
Joined: Tue Jan 25, 2011 5:20 pm

Re: "Disconnected : Error connecting to server"

Postby raf » Tue Jan 25, 2011 6:36 pm

Hi, Linux works fine with Remoter. I personally like tightvnc (http://en.opensuse.org/TightVNC), and to start the server I do:
Code: Select all
vncserver :1 (or startvncserver :1)

Found this: http://opensuse.swerdna.org/susetightvnc.html#install

This starts a vnc session using desktop 1 (which maps to port 5901). But Vino works as well, and will VNC your root X server, so you connect to 5900 (or :0).

All you really need to enter in remoter are the fields displayed without tapping the "Advanced" button (A name for the connection, your computer hostname or ip address, optionally with a desktop/port number (so computerX:5900, computerX:0 and computerX all will work for desktop 0) and the VNC password. I'll be posting a video on how to configure Linux; but I'll be using Ubuntu. I'm sure for Suse it will be similar.

To make sure your system is indeed running the VNC server, open a terminal and type:
Code: Select all
telnet localhost 5900


If you don't get a message like:

Code: Select all
$ telnet localhost 5900
Trying ::1...
Connected to localhost.
Escape character is '^]'.
RFB 003.889


It means your VNC is either not running, or not running on port 5900.

Edit: added note about how to install in OpenSuse
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am

Re: "Disconnected : Error connecting to server"

Postby Igel » Sun Feb 06, 2011 7:05 pm

Hi,

Thanks for trying to help. Unfortunately, it's still not working.
I think I tried everything you recommended, starting the vncserver by using "vncserver" and setting the password by using "vncpasswd".

I cannot use port 5900 because after entering "vncserver :0" I get

Warning: mycomputer:0 is taken because of /tmp/.X11-unix/X0
Remove this file if there is no X server mycomputer:0
A VNC server is already running as :0

This seems to be normal on linux as I found on the web-page you recommended (http://opensuse.swerdna.org/susetightvnc.html#install - Thanks for that one!):

"In Linux, TightVNC windows start from :1 (window :0 being unavailable). Most normal Linux users would only be concerned with :1 and ports 5801/5901."

So, I tried :1 and indeed this worked and "telnet localhost 5901" results in

Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
RFB 003.007

Still, I can't get any connection from the iPhone. It might have to do with the firewall as I read in another thread in this forum. I'll try to read about that during the week. I also installed tightvnc v1.5.2 on a windows XP laptop I have temporarily available and got, surprise:

"Disconnected : Error connecting to server"

But of course, there is a firewall running there, too (on which computer isn't?)

Meanwhile, could you please help by clarifying a few things about the prompts in your app?

"Host Name:"
In case I try to use a real name here, would it be "mydomain.mycomputer:5901"? Or could I omit the port number (although my port is NOT 5900)?
In case I try to use an IP adress, would it be the local one, i.e. 192.168.2.101 or the global one, I get from http://www.whatismyip.com ?
And again, :5901 entered behind the IP?

"Username/Password"
When and where should I enter my login name and password for the linux system? Do I have to activate it in the "advanced" section or would my computer allow a connection without that information?

On the windows system my username is within a domain, not a local user. So, would I have to activate username and password in the advanced section and enter it in the form: "mydomain\myusername " or "mydomain/myusername", or any other way?

Thanks again for helping out.

Igel
Igel
 
Posts: 3
Joined: Tue Jan 25, 2011 5:20 pm

Re: "Disconnected : Error connecting to server"

Postby raf » Sun Feb 06, 2011 10:37 pm

Hi!,
Sorry to hear your still having problems..

Igel wrote:So, I tried :1 and indeed this worked and "telnet localhost 5901" results in

Trying ::1...
telnet: connect to address ::1: Connection refused
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
RFB 003.007

Still, I can't get any connection from the iPhone.


If you're connecting to desktop 1 (or port 5901) you need to specify that after the hostname/ip address:

hostname: mycomputer:1
or mycomputer:5901


It might have to do with the firewall as I read in another thread in this forum. I'll try to read about that during the week. I also installed tightvnc v1.5.2 on a windows XP laptop I have temporarily available and got, surprise:

"Disconnected : Error connecting to server"

Make sure the VNC service is running on the windows box, I recommend TightVNC 1.3.10 and no higher at this point, as higher versions are still under development and have a lot of issues, at least with Remoter, at the moment.

Meanwhile, could you please help by clarifying a few things about the prompts in your app?
"Host Name:"

Sure, in the next version of Remoter help will be available for each element:
Screen shot 2011-02-06 at 9.24.46 PM.png
Screen shot 2011-02-06 at 9.24.46 PM.png (16.72 KiB) Viewed 8622 times


Under hostname you can enter:
mycomputernameonthenetwork:5901 (or 192.168.1.111:5901 if using an IP, of course replace with the real IP address).
or
mycomputernameonthenetwork:1 (this maps to 5901)
or
mycomputernameonthenetwork:-1234 (for arbitrary ports, in this case you would connect to a VNC server running at port 1234)

The only case when you can omit the port number is when the VNC server is running at 5900.

Use a local IP if connecting from inside your LAN, use your real internet IP address if connecting from the internet; in which case you need to make sure to set up port forwarding on your router to forward port 5901 (in your case) to your internal IP at port 5901.

"Username/Password"
When and where should I enter my login name and password for the linux system? Do I have to activate it in the "advanced" section or would my computer allow a connection without that information?

Username is only used for MSLogon in Windows, if you have this feature enabled and are using UltraVNC.
Password is the VNC password, it's independent from any user password on any system.

On the windows system my username is within a domain, not a local user. So, would I have to activate username and password in the advanced section and enter it in the form: "mydomain\myusername " or "mydomain/myusername", or any other way?

Only if you have UltraVNC and have MSLogon enabled (look at the video guides on how to set up), you need/can use the domain:

Screen shot 2011-02-06 at 9.36.33 PM.png
Screen shot 2011-02-06 at 9.36.33 PM.png (14.46 KiB) Viewed 8622 times


Hope this helps!,

Raf.
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am

Re: "Disconnected : Error connecting to server"

Postby Igel » Mon Mar 07, 2011 6:21 pm

Hi,


thanks for the help. It took a while but now I can announce: I got a connection!
To be accurate: two connections: One to my linux netbook and one to my windows notebook. Both running tightVNC.

To achieve this, I had to open the ports in the firewalls and to configure the vncserver on the linux system as described in the above mentioned web-page. On windows I installed the tightVNC and opened the ports in the firewall, again as described on that web-page.

Then I entered the local IP-address as explained by Ralf above. I didn't even have to add a port with a colon after it, although adding :0 or :5900 worked, too.

There were two more little "tricks" I had to do: Firstly, on the openSuse Linux netbook, I had to start the KDE tool "Krfb" (Menue: System>Remote Acess>Krfb). This opens a window where I could "Configure>Security" "Allow uninvited connections" and define a password for that connections (the same password I entered in "Remoter"). This also opens a little tray icon called "Desktop Sharing" which seems to control the connections. When I try to connect from the iPhone with "Remoter" it opens up a little window on the computer, asking whether I want to grant the connection. This tool uses port 5900 by the way, so it's the same as for windows.

Secondly, I always had to enter the IP-address (the local one as I'm connecting from within my WLAN). If I enter the hostname in the form domain.computername I only get the often mentioned error message. This is, although "Remoter" seems to find the computer (because I get a different error message if I omit the domain name: "couldn't convert .... to host adress". On second thought, it might not know the computer, after all, because I also get "Disconnected, error connecting to server" if I mistype the ip address). This is true for the Linux as well as for the Windows laptop.

OK, but so eventually it worked (and I learned something about firewalls)!


On windows, everything's fine now (although working slowly). On Linux there's still some issue: The desktop on the iPhone looks very strange - red, green and black rectangles all over the place, I can hardly recognize anything (I put a picture here: http://db.tt/MpCBUHu). I guess, it could have to do with the big screen resolution (fullHD). Reducing or increasing the colour depth didn't help. It's the same strange picture, if I connect from the Windows laptop to the Linux netbook, so it's not an original issue of "Remoter". Still, any help is welcome.

Anyway, thank you for the help and the neat tool!

Igel
Igel
 
Posts: 3
Joined: Tue Jan 25, 2011 5:20 pm

Re: "Disconnected : Error connecting to server"

Postby raf » Mon Mar 07, 2011 7:33 pm

Thanks so much for sharing all that, Igel. I'm sure it will be of help to more than one.

About the weird desktop you get in linux (thanks for mentioning this happens even when connecting from Windows, Linux, so it's not an issue with Remoter). I'm not sure what the problem is; but I would try some other VNC servers on your Linux box. You can run tightVNC on Linux, which I recommend, but it creates it's own X session, which can be confusing at first, but something I personally love.

Raf.
raf
Site Admin
 
Posts: 1691
Joined: Sat Oct 09, 2010 12:17 am


Return to Support

Who is online

Users browsing this forum: No registered users and 6 guests

cron
cron