Page 2 of 2

Re: Login issue

PostPosted: Sun Nov 07, 2010 8:42 pm
by Ldee
the plot thickens...
"telnet localhost 5900" works on both machines! (when screen sharing is enabled)

I tried the restart method, disabling screen sharing, rebooting, re-enabling screen sharing - no luck, I get "server error" on the iPad all the time if I try Remoter again

I did some research on the web, and found a few ideas:

1. one guy said he had similar problems, then he went to Activity Monitor to see if NetAuthAgent was working. If it says "not responding" then that could be the problem. Well, I go to Activity Monitor, select All Processes, but there is NO NetAuthAgent listed... I search for it, find it in System/Library/CoreServices/, I remove it to the desktop, reboot, hoping the System will generate a fresh new version - no luck, no new version, VNC still no good, dragged it back, still no good

2. another guy ( suggested doing the same with the file "" (in Library/Preferences/), done it, no good either

Couple of other thoughts:

In my Activity Monitor there is something called AppleVNCServer. Could this be the source of the problem? Know anything about this file?

Another clue (perhaps) (unrelated to Remoter but very much related to screen sharing):

I canNOT share the screen between the two machines (with Screen Sharing enabled on both)! When I try in on the "good" machine (which Remoter can access fine), I get a progress bar forever saying "Connecting to BadComputer..." and nothing happens.
When I try it on the "bad" machine (the one Remoter can no longer access), it asks me for my name and password. None of the bad computer's names (long, short, the one shown in the Sharing panel, etc.) and none of the passwords I can think of work.
In other words, trying screen sharing from the good computer does not ask for authentication, but the other way it does, and will not accept any of the names/passwords.
Do you know how to get to these names/pws ? Could my Keychain be corrupted and cause the Remoter access problem ("Server error") as well?

Still another clue:
When I use another iPad app called PC Access (which can "discover" servers automatically - by the way, this feature would be great in a future release of Remoter!), it always discovers my "bad computer" (in other words, it lists it as an available server) but then fails to connect to it, just like Remoter.

Any thoughts?
(I promise this is the last time I will bother you with this!)

Re: Login issue

PostPosted: Sun Nov 07, 2010 10:42 pm
by raf
Sounds like there is something wrong with Bad computer. Like you suspect, probably some corrupted file somewhere. You could try creating a brand new user account just for testing, and setting up Screen Sharing from there. Maybe the corruption/problem is isolated to your current user account.

I'm still interested in the output from your "Telnet localhost 5900", as the details from that output can shed some light as well.

AppleVNCServer is the VNC server process. It's a good thing that it's there.

Reinstalling Leopard seems like might be the only solution if all else fails.


PS: The other thing you can do is install the free Vine VNC Server ( , described in Remoter's help). Be sure to disable Screen Sharing if you try this.

PS2: Bonjour auto-detection is coming to Remoter soon.

Re: Login issue

PostPosted: Mon Nov 08, 2010 2:16 pm
by Ldee

I am away from my house for a couple of days, but when I get home I will check and send you the telnet result, although my recollection is that it was exactly what you said it should be...

I will also try your suggestions: a new account and the free Vine VNC Server. Reinstalling Leopard will be my last resort...

The fact that the auto detection does detect the bad computer as a working server doesn't give you any clues? Sounds like the bad computer does work as a server (broadcasts itself OK), only for some reason does not allow access to it. Authentication issue?

The search for the solution continues. I don't know if I should laugh or cry.

Re: Login issue

PostPosted: Thu Nov 11, 2010 10:42 am
by raf
Let me know if any of the suggestions helped. Also, the exact details of the output of the telnet command CAN definitely help.


Re: Login issue

PostPosted: Thu Nov 11, 2010 8:04 pm
by Ldee
Thank you very much, Raf, for your interest and readiness to help!
Right now I am very happy, I got the darn thing to work! Finally!

I know you want to know how, so here is the short version: I downloaded Vine Server, but it did NOT work either. I checked the Console Log as well, it said many times "connection rejected" (both to Apple's built-in VNC server and to Vine Server), so it looked like my BAD computer was actually all right, except for some reason it decided not to allow incoming traffic. I decided to see if I can do anything about it in the Security/Firewall area of System Prefs. I changed the radio button from "Allow only essential services" to "Set access for specific services..." and added Vine Server with "Allow incoming connection". This seems to have done it. I went to my iPad and both Remoter and PC Access had no trouble now accessing the BAD computer.

What's more, after this I decided to go back and try Apple's built-in VNC server. And now it, too, worked fine! Then I went to my GOOD computer, and Remoter was just fine on it, as before, using Apple's built-in VNC server (Screen Sharing). Then I went back to the BAD guy, tried again, still fine, and checked the Firewall panel, and suddenly both OSXvnc-server and AppleVNCServer.bundle are listed, besides Vine Server, in the list of apps allowing incoming connections.

One LAST question: in the Firewall panel we have 3 choices: "Allow all incoming connections", "Allow only essential services" and "Set access for specific services...". My good computer is on choice 1, the BAD one is now on choice 3. Any ideas about which choice is the best (or necessary) for occasional VNC usage? (No other incoming connection that I am aware of, other than the Internet.)

Finally, just in case you still want to see it, here is the telnet reply I get when Screen Sharing is on:

Last login: Mon Oct 11 10:37:18 on console
$ telnet localhost 5900
Trying ::1...
Connected to localhost.
Escape character is '^]'.
RFB 003.889

I believe this is exactly the same as what you wrote a little while ago.

By the way, you may be interested to hear that it looks like the connection is much faster and smoother in Remoter thru Apple's built-in server than thru Vine Server! I thought it was supposed to be the other way around!...

Finally, I can't wait for 1.6! Thanks for the great work!

Re: Login issue

PostPosted: Thu Nov 11, 2010 8:40 pm
by raf
This is great news, thanks for letting me know, and your thorough explanation on how to correct the problem! It really never crossed my mind this was a firewall issue. Very interesting! I'm sure this knowledge will prove useful in the future. I might even add it to the guides.
As far as which is the best setting for the firewall. That's up to you. Personally I have the firewall disabled, not that I would recommend that. I think the third option sounds good, that way you have better control over what is allowed to accept connections..

Thanks for sharing!,