Page 1 of 1

Remoter VNC 3.6.0 is out! (3.6.3 now)

PostPosted: Mon May 14, 2012 10:03 pm
by raf
Should be getting approved soon, and out in a day or two.
Update 05/16: is out now!
Update 06/02: 3.6.2 is now out!
Update 06/21: 3.6.3 is now out (minor hot-fix release)

-New IAP: Password Manager (also included in Remoter Complete IAP)
-New IAP: Grid UI (new session selection UI) (also included in Remoter Complete IAP)
-Added retina support to 1:1 zoom level
-Added retina support to SSH/Telnet auto-mode.
-RDP, In Session Editor: Added option to enter custom RDP resolutions.
-Lots of updates to session animations for switching between sessions, going back to session list, continue sessions, on session disconnect, etc.
-Updated animations for connection / disconnection.
-Re-organized some of the RDP resolutions so that the most populars are shown first.
-Better external keyboard detection: always automatic now.
-Added support for right-dragging
-Added support for the "PrintScr" key through the "Send" menu.

-Some bug fixes.
-Correct some graphical issues on rotation.
-Enabled height cache for session editor and remoter config. This greatly speeds up scrolling on these screens.
-Renamed "Folder" to "Category" in session list.
-Corrections for legacy selection screen so that thumbnails are not left visible when connected.
-Fix for NLA error being presented at the wrong time.
-Fix for Aqua Connect
-RDP: NLA disabled doesn't disable regular RDP security anymore.

05/23/12: Updated to 3.6.1:
What's New:
-Added connection type to request for username/password combined alerts.
-Updates to password encryption system. More secure now.
-If categories are not defined, notify user if they try to use the category button.

Bug Fixes:
-Fixed problem in connectionDialog, where it would be displayed behind sessions.
-Fixed problem with Request Username / password
-Cleanup. Fixed memory leaks.
-Memory management changes for VNC pointer.
-Remoter Store: query on screen creation every time.
-Fixed password manager iOS title incorrectly displayed as "Macros Manager"
-Fix for issue where when disconnecting from a second session, and then rotating would reveal part of the first session.
-Fix for putty windows not rendering correctly in RDP (disable glyph cache)

Re: Remoter VNC 3.6.0 is out!

PostPosted: Mon May 21, 2012 9:57 am
by WayneLouis
Ever since upgrading to this version, one of the machines I used to be able to connect to immediately exits/crashes the app.

I even created a new config to connect to the machine and it does the same thing.

Is there a way that I can debug/log what's happening?

BTW -- the session type is VNC over SSH.

I have it set to ask me for the SSH password and I have given it the VNC password as part of the config. It accepts the SSH password and then tells me its creating a tunnel and then I'm greeted with the ipad's main screen. (This is an ipad 3, btw.)

I tried it with and without asking for VNC password. I tried it at both 16 and 32 bpp. I tried it with VNC alt encoding off and on. In all cases, the session crashes and I go back to the ipad home screen. If I check the list of apps, remoter is still running, just no session I tried to just start.

Re: Remoter VNC 3.6.0 is out!

PostPosted: Mon May 21, 2012 10:14 am
by WayneLouis
okay, the problem I'm having is more general than I thought.

I can't get a simple SSH session to open. Without the VNC stuff, I just set up a simple ssh session. I tried it to a couple of different machines with the same result as above.

But, not to all hosts. One ssh session I'd previously set up works, and from the the machine that I've ssh'd into, I can ssh into the other machines that I couldn't get to directly above.

I'm baffled.

Re: Remoter VNC 3.6.0 is out!

PostPosted: Tue May 22, 2012 8:44 pm
by raf
Hi Wayne,
You're not alone. Several users have reported this issue. This has now been corrected, and version 3.6.1 was submitted earlier today to Apple.
Let's hope for a quick turn-around.
The main problem is related to the "Request Username", "Request Password" features. As a temporary work around: if you turn them off, and use the Security Pin feature in Remoter Config in the mean time, you should be able to connect to your servers.

I'm really sorry about this inconvenience, and I thank you for your report!,

Re: Remoter VNC 3.6.0 is out! (3.6.1 now)

PostPosted: Wed May 23, 2012 9:26 pm
by raf
Apple performed an expedited review on 3.6.1. It has been now approved, and is now out. Please update.


Re: Remoter VNC 3.6.0 is out! (3.6.1 now)

PostPosted: Fri May 25, 2012 6:13 pm
by raf
Current 3.6.1 Issues:
-Blank screen when coming back to Remoter: *Corrected for 3.6.2 (pro 1.0.3) (5/25/12)
-SSH Manager not working *Corrected for 3.6.2 (pro 1.0.3) (5/25/12)

Please report any other issues. Thank you!

Re: Remoter VNC 3.6.0 is out! (3.6.1 now)

PostPosted: Wed May 30, 2012 7:43 am
by mavit12
Just to clarify, is the fix to the SSH key manager in 3.6.1 or 3.6.2?

*EDIT* Sorry, I just read the above post more clearly. *sigh* Any expectation of when 3.6.2 will be approved? I need the manager for several of my connections (only key authentication over ssh).

Re: Remoter VNC 3.6.0 is out! (3.6.1 now)

PostPosted: Thu May 31, 2012 10:02 am
by raf
The SSH Manager fix is in 3.6.2.
Unfortunately, from the point updates are submitted to Apple, developers have no control as to how long it will take for Apple to review.
All I know at this point is that the app is in the "Waiting For Review" state. But based on experience, since it was submitted last Friday, we should expect the update to be live around this weekend.


Re: Remoter VNC 3.6.0 is out! (3.6.2 now)

PostPosted: Sat Jun 02, 2012 7:26 am
by raf
Remoter VNC 3.6.2 is now out, please update!